2-in-1 Credit Card Reader




Devices that are compatible with the PayAnywhere 2-in-1 Bluetooth Credit Card Reader

  • Requires iOS 6.0 or above
  • iPhone 4S or above
  • iPad 3rd Gen or above
  • iPad Pro 1st Gen

Devices that are NOT compatible with the PayAnywhere 2-in-1 Bluetooth Credit Card Reader

  • iPad 1st and 2nd Gen
CHAT WITH US